FIRE / ESM SYSTEMS TESTING - L [BUNDOORA]

Scheduled for Sep 29, 06:00 AEST  -  Sep 30, 16:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 29, 2025 - 14:16 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 29, 2025 - 14:13 AEST

Scheduled

Scheduled maintenance testing of the fire and essential safety measures systems is taking place in the Library on Tuesday 2 Sept 25 from 6:00am to 3 Sept 25 at 4:00pm. Tones may sound during this time.
Posted Aug 29, 2025 - 14:13 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (L | Library).