POWER OUTAGE - L, SS, ELT, DW, MAR, HU3, AE, AT [BUNDOORA]

Scheduled for Sep 23, 18:00 AEST  -  Sep 24, 06:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 12, 2025 - 12:01 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 12, 2025 - 12:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 12, 2025 - 11:58 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 12, 2025 - 11:51 AEST

Scheduled

The power supply to the Library, Social Sciences, Eastern Lecture Theatres, Donald Whitehead, Martin Building, Humanities 3, Agora East and Agora Theatre will be interrupted on Tuesday 23rd Sep 25 from 6:00pm to 6:00am Wednesday 24th Sep 25 to allow for critical Infrastructure Electrical Systems upgrades.
Posted Sep 12, 2025 - 11:51 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (AT | Agora Theatre, AE | Agora East, DWB | Donald Whitehead Building, ELT | East Lecture Theatres, HU3 | Humanities 3, L | Library, MAR | Martin Building, SS | Social Sciences).