PROJECT/BUILDING FABRICS WORKS - AT [BUNDOORA]
Scheduled for Feb 6, 07:00 - 17:00 AEDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 17, 2025 - 14:16 AEDT
Scheduled
Agora Theatre will be undergoing building fabrics works. The estimated time of completion is Thursday 6 Feb 25. This project may generate some construction noise during this time.
Posted Jan 17, 2025 - 14:16 AEDT
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (AT | Agora Theatre).