WATER OUTAGE - L BUNDOORA]

Incident Report for LTU | Outages

Resolved

This incident has been resolved.
Posted May 01, 2026 - 09:23 AEST

Monitoring

The male toilets external of the library have been closed off due to a burst pipe. We aim to have this resolved as soon as possible.
Posted Apr 13, 2026 - 11:43 AEST
This incident affected: Melbourne (Bundoora) Campus Buildings (L | Library).