PROJECT WORKS - LIFT UPGRADES - TLC, PS1, RLR, DW [BUNDOORA]

Scheduled for Nov 18, 2025, 07:00 AEDT  -  Feb 20, 2026, 15:00 AEDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 12, 2025 - 13:54 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 12, 2025 - 13:48 AEST

Scheduled

Donald Whitehead Building, Physical Sciences 1, R.L.Reid Building, The Learning Commons will be undergoing Lift Upgrades. The estimated time of completion is 3:00pm Friday 20th February 2026. This project may generate some construction noise during this time.
Posted Sep 12, 2025 - 13:48 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (DWB | Donald Whitehead Building, PS1 | Physical Sciences 1, RLR | R.L.Reid Building, TLC | The Learning Commons).