AIR-CONDITIONING OUTAGE - AW [BUNDOORA]
Incident Report for LTU | Outages
Resolved
This incident has been resolved.
Posted May 12, 2021 - 10:25 AEST
Identified
Air-conditioning services in Agora West level 1 and 2 have been interrupted. The I&O team are working to identify the cause and implement a solution. A time frame for restoration of services will be published as soon as it is available.
Posted Oct 24, 2019 - 16:06 AEDT
This incident affected: Melbourne (Bundoora) Campus Buildings (AW | Agora West).