POWER OUTAGE - R3 [BENDIGO]

Scheduled for Dec 3, 09:00 - 15:00 AEDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 18, 2025 - 15:29 AEDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 18, 2025 - 15:22 AEDT

Scheduled

The power supply to Robert Holmes Village will be interrupted on Wednesday 3rd November from 9:00am - 3:00pm to allow for scheduled maintenance works.
Posted Nov 18, 2025 - 15:21 AEDT
This scheduled maintenance affects: Bendigo Campus Buildings (R3 - Robert Holmes Village).