POWER OUTAGE / SAFETY SWITCH TESTING - SHS [SHEPPARTON]

Scheduled for May 17, 07:00 - 19:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted May 04, 2026 - 08:34 AEST

Scheduled

The power supply to the Shepparton Campus Building will be interrupted on SUNDAY 17 MAY 2026 from 7:00AM - 7:00PM to allow for Residual Current Device (RCD) / safety switch testing. These works will incur a minor power outage for up to 10 seconds on each circuit tested.
Posted May 04, 2026 - 08:32 AEST
This scheduled maintenance affects: Shepparton Campus Buildings (SHS | Shepparton Campus Building).