POWER OUTAGE - LIMS2 [BUNDOORA]

Scheduled for Aug 25, 06:30 - 07:30 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 24, 2026 - 10:10 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 24, 2026 - 08:34 AEST

Scheduled

The power supply to LaTrobe Institute For Molecular Science 2 Level 2 will be interrupted on TUESDAY 25TH AUGUST 2026 from 6:30AM to 7:30AM allow for scheduled maintenance works.
Posted Aug 24, 2026 - 08:33 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (LIMS2 | LaTrobe Institute For Molecular Science 2).