PROJECT WORKS/ACCESS - LIMS1, BS1 [BUNDOORA]

Scheduled for Mar 24, 08:00 AEDT  -  Mar 31, 15:00 AEDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 20, 2026 - 13:06 AEDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 20, 2026 - 13:05 AEDT

Scheduled

The forecourt between Biological Sciences 1 and LaTrobe Institute For Molecular Science 1 walkway and external seating will be undergoing maintenance works. The estimated time of completion is Tuesday 31 Mar 26 at 3:00pm. This project may generate some noise and there will be access restrictions during this time.
Posted Mar 20, 2026 - 13:05 AEDT
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (BS1 | Biological Sciences 1, LIMS1 | LaTrobe Institute For Molecular Science 1).