WATER OUTAGE - CC-B3 [BUNDOORA]

Scheduled for May 22, 10:30 - 13:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted May 21, 2026 - 08:32 AEST

Scheduled

The water supply to Chisholm College Block 3 building will be interrupted on FRIDAY 22 MAY 2026 from 10:30AM to 1:00PM to allow for scheduled maintenance works.
Posted May 21, 2026 - 08:32 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (CC | Chisholm College- All Blocks / Buildings).