WATER OUTAGE - ED2 [BUNDOORA]

Scheduled for Aug 25, 12:00 - 16:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 24, 2026 - 16:01 AEST

Scheduled

The water supply to Education 2 building will be interrupted on TUESDAY 25TH AUGUST 2026 from12:00PM to 4:00PM to allow for scheduled maintenance works.
Posted Aug 24, 2026 - 16:01 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (ED2 | Education 2).