WATER OUTAGE - MAR [BUNDOORA]

Scheduled for Sep 9, 07:00 - 09:30 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 08, 2026 - 15:42 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 08, 2026 - 15:38 AEST

Scheduled

The water supply to Martin Building will be interrupted on WEDNESDAY 9TH SEPTEMBER 2026 from 7AM - 9:30AM to allow for scheduled maintenance works.
Posted Sep 08, 2026 - 15:38 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (MAR | Martin Building).