Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 14, 2025 - 07:00 AEDT
Scheduled
The power supply to Biological Sciences 1, Education 1, Education 2, Health Sciences 1, Health Sciences 2, Health Sciences 3, Health Science Clinic, Western Lecture Theatre, NR1, NR2, NR3&4, NR6, NR7, NR8, Peribolos East, Peribolos West, Physical Sciences 2, Sports Park Pavillion, Union and La Trobe Lifeskills will be intermittently interrupted on Tuesday 14 January 2025 from 07:00am to 4:00pm to allow for Residual Current Device (RCD) / safety switch testing. These works will incur a minor power outage for up to 10 seconds on each circuit tested.
Posted Jan 09, 2025 - 13:35 AEDT
This scheduled maintenance affected: Melbourne (Bundoora) Campus Buildings (BS1 | Biological Sciences 1, ED1 | Education 1, ED2 | Education 2, HS1 | Health Sciences 1, HS2 | Health Sciences 2, HS3 | Health Sciences 3, HSC | Health Sciences Clinic, NR1 | Annexe 1- Institute for Advanced Study, NR2 | Confucius Institute, NR3 | La Trobe Apartments, NR4 | La Trobe House, NR6 | Centre for Research on Language Diversity, NR7 | Graduate House - East, NR8 | Michael J Osborne Centre- Administration, PE | Peribolos East, PS2 | Physical Sciences 2, PW | Peribolos West, SPP | Sports Park Pavilion, U | Union Building, UCC | Lifeskills Building, WLT | West Lecture Theatres).