AIR-CONDITIONING OUTAGE - SW [BUNDOORA]

Scheduled for May 14, 12:00 AEST  -  May 15, 12:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted May 04, 2026 - 14:13 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted May 04, 2026 - 14:12 AEST

Scheduled

Air-conditioning services in the Sylvia Walton building will be unavailable on THURSDAY 14 MAY 2026 from 12:00AM until FRIDAY 15 MAY 2026 12:00AM to allow for scheduled project works.
Posted May 04, 2026 - 14:12 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (SW | Sylvia Walton building).