POWER OUTAGE / SAFETY SWITCH TESTING - HU3 [BUNDOORA]

Scheduled for Sep 11, 07:00 - 08:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 10, 2026 - 11:06 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 10, 2026 - 11:05 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 10, 2026 - 11:04 AEST

Scheduled

The power supply to Humanities 3 will be interrupted on FRIDAY 11TH SEPTEMBER 2026 from 7:00AM to 8:00AM to allow for Residual Current Device (RCD) / safety switch testing. These works will incur a minor power outage for up to 10 seconds on each circuit tested.
Posted Sep 10, 2026 - 11:02 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (HU3 | Humanities 3).