HEATING OUTAGE - PS2 [BUNDOORA]

Scheduled for May 12, 06:00 - 10:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted May 04, 2026 - 14:08 AEST

Scheduled

Heating services in the Physical Sciences 2 building will be unavailable on TUESDAY 12 MAY 2026 from 6:00AM - 10:00AM to allow for scheduled project works.
Posted May 04, 2026 - 14:08 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (PS2 | Physical Sciences 2).