FIRE / ESM SYSTEMS TESTING - EP1 [BUNDOORA]

Scheduled for Sep 16, 08:00 - 16:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 15, 2026 - 17:01 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 15, 2026 - 16:59 AEST

Scheduled

Scheduled maintenance testing of the fire and essential safety measures systems is taking place in BM Latrobe House on WEDNESDAY 16TH SEPTEMBER 2026 from 8:00AM to 4:00PM. Tones may sound during this time.
Posted Sep 15, 2026 - 16:59 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (EP1| BM La Trobe House).