AIR-CONDITIONING OUTAGE - MC-DH [BUNDOORA]

Incident Report for LTU | Outages

Update

We are continuing to work on a fix for this issue.
Posted Jan 28, 2026 - 14:11 AEDT

Identified

Air-conditioning services in Menzies College Dining Hall level 2 Rooms 201, 201a & 202 have been interrupted due to unscheduled maintenance works. We aim to have these services back online as soon as possible.
Posted Jan 28, 2026 - 14:11 AEDT
This incident affects: Melbourne (Bundoora) Campus Buildings (MC | Menzies College).