POWER OUTAGE / GENERATOR TESTING - AW8 [ALWOOD]

Scheduled for Sep 25, 15:11 - 16:11 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 09, 2025 - 15:14 AEST

Scheduled

The power supply to Nancy F Millis Building (MDFRC) will be interrupted on Thursday 25 Sept 25 from 10:00am - 11:00am to allow for Generator Building Load testing. These works will incur a minor power outage
Posted Sep 09, 2025 - 15:14 AEST
This scheduled maintenance affects: Albury Wodonga Campus Buildings (AW-8 | Nancy F Millis Building (MDFRC)).