ANNUAL HEATING, COOLING & DOMESTIC HOT WATER OUTAGE - BG, ED1, ED2, HU2, PW, PS1, PS2, RLR [BUNDOORA]
Scheduled for Dec 22, 2025, 07:00 AEDT - Jan 19, 2026, 17:00 AEDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 05, 2025 - 16:09 AEDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 05, 2025 - 16:07 AEDT
Scheduled
Heating, Cooling and Domestic Hot Water services in Beth Gleeson Building, Education 1 & 2, Humanities 2, Peribolos West, Physical Sciences 1 & 2, R.L.Reid Building will be unavailable on Monday 22 Dec 25 from 7:00am - 5:00pm Monday 19 Jan 26, due to the Annual campus service shutdown. The annual shutdown is essential to the La Trobe University planned maintenance program and will take place in early January 2026. The shutdown consolidates essential work on the University's critical infrastructure, reduces unexpected outages throughout the year and contributes to the reliability of key University infrastructure.