HEATING OUTAGE - AW1 [ALBURY WODONGA]

Incident Report for LTU | Outages

Update

We are continuing to work on a fix for this issue.
Posted Sep 24, 2026 - 16:20 AEST

Identified

Heating services in AW1 have been interrupted due to unscheduled maintenance works. We aim to have these services back online as soon as possible.
Posted Sep 24, 2026 - 16:20 AEST
This incident affects: Albury Wodonga Campus Buildings (AW1 | David Mann Library).