HEATING OUTAGE - SHS [SHEPPARTON]
Incident Report for LTU | Outages
Resolved
This incident has been resolved.
Posted May 12, 2021 - 10:24 AEST
Investigating
Heating services in Shepparton Campus Building have been interrupted. The I&O team are working to identify the cause and implement a solution.
Posted Mar 02, 2021 - 08:57 AEDT
This incident affected: Shepparton Campus Buildings (SHS | Shepparton Campus Building).