PROJECT WORKS - DMC [BUNDOORA]

Scheduled for Jun 11, 11:17 AEST  -  Jun 16, 20:17 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 01, 2026 - 11:28 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 01, 2026 - 11:28 AEST

Scheduled

The David Myers Centre building level 2 will be undergoing building fabric works. The estimated time of completion is at 3:00pm on Tuesday 16th June 2026. This project may generate some construction noise and access to the footpath on level 1 will be closed during this time.
Posted Jun 01, 2026 - 11:27 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (DMC | David Myers Building- Centre).