PROJECT FABRIC WORKS - CS1, CS2, CS3 [BUNDOORA]

Scheduled for Jun 30, 13:00 AEST  -  Jul 1, 07:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 29, 2026 - 10:17 AEST

Scheduled

The Campus Services 1, 2 and 3 buildings will be undergoing stair fabric works. The estimated time of completion is 7:00AM on Wednesday 1st July 2026. This project will have pedestrian access restrictions to CS2 during this time.
Posted Jun 29, 2026 - 10:17 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (CS1 | Campus Services 1 (I&O), CS2 | Campus Services 2).