AIR-CONDITIONING OUTAGE - ET [BENDIGO]
Incident Report for LTU | Outages
Resolved
This incident has been resolved.
Posted May 12, 2021 - 10:24 AEST
Investigating
Air-conditioning services in Engineering and Technology Building have been interrupted. The I&O team are working to identify the cause and implement a solution.
Posted Mar 01, 2021 - 09:25 AEDT
This incident affected: Bendigo Campus Buildings (ET | Engineering and Technology Building).