Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 13, 2025 - 08:00 AEDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 27, 2024 - 09:21 AEDT
Scheduled
The Library, Social Sciences, Martin, Biological Sciences 1 & 2, LaTrobe Institute for Molecular Science 1 and The Learning Commons Buildings are currently undergoing construction works around the elevated walkways surrounding the library. Walkway will have restricted access; project may generate some construction noise during this time. Estimated time of completion is 2 Mar 2025.
Posted Nov 27, 2024 - 09:21 AEDT
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (BS1 | Biological Sciences 1, BS2 | Biological Sciences 2, L | Library, LIMS1 | LaTrobe Institute For Molecular Science 1, MAR | Martin Building, SS | Social Sciences, TLC | The Learning Commons).