PROJECT WORKS - CS1, CS2 [BUNDOORA

Scheduled for Aug 18, 07:00 AEST  -  Aug 22, 15:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 13, 2026 - 14:49 AEST

Scheduled

Campus Services Buildings 1 and 2 will be undergoing HTHW Culvert Works. The estimated time of completion is 3:00PM on SATURDAY 22ND AUGUST 2026. This project may generate some construction noise and access restrictions during this time.
Posted Aug 13, 2026 - 14:49 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (CS1 | Campus Services 1 (I&O), CS2 | Campus Services 2).