WATER OUTAGE - HU3, CSCS [BUNDOORA]

Incident Report for LTU | Outages

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 14:50 AEST

Update

We are continuing to monitor for any further issues.
Posted Jun 18, 2026 - 10:36 AEST

Monitoring

The water supply to HU3 has been interrupted due to unscheduled maintenance works. We aim to have these services back online as soon as possible.
Posted Jun 17, 2026 - 11:15 AEST
This incident affected: Melbourne (Bundoora) Campus Buildings (CSCS | Cycle Smart Centre South, HU3 | Humanities 3).