HEATING OUTAGE - HU2 [BUNDOORA]

Incident Report for LTU | Outages

Update

We are continuing to work on a fix for this issue.
Posted Apr 13, 2026 - 15:46 AEST

Identified

Heating services on the east side of HU2 have been interrupted due to unscheduled maintenance works. We aim to have these services back online as soon as possible.
Posted Apr 13, 2026 - 14:31 AEST
This incident affects: Melbourne (Bundoora) Campus Buildings (HU2 | Humanities 2).