POWER OUTAGE - BS1 [BUNDOORA]

Scheduled for Jun 26, 05:30 - 07:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 25, 2026 - 12:27 AEST

Scheduled

The power supply to Biological Sciences 1 will be interrupted on Friday 26th June 2026 from 5:30AM - 7:00AM to allow for scheduled maintenance works.
Posted Jun 25, 2026 - 12:27 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (BS1 | Biological Sciences 1).