PROJECT WORKS - DMC [BUNDOORA]

Scheduled for Jun 15, 07:00 AEST  -  Jul 31, 15:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 01, 2026 - 12:03 AEST

Scheduled

David Myers Centre building level 2 will be undergoing Balustrade upgrade. The estimated time of completion is at 3:00pm on Friday 31st July 2026. This project may generate some construction noise and there will be restricted access from DMC level 1 to the International Garden. External walkway on Level 2 will remain open with reduced width during this time.
Posted Jun 01, 2026 - 11:54 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (DMC | David Myers Building- Centre).