POWER OUTAGE/RCD REPLACEMENT - HU3 [BUNDOORA]
Scheduled for Nov 22, 07:00 - 08:30 AEDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 21, 2024 - 11:50 AEDT
Scheduled
The power supply to Humanities 3, Levels 1,2 & 4 will be interrupted on Friday 22 Nov 24 from 7:00AM to 8:30AM to allow for scheduled maintenance works.
Posted Nov 21, 2024 - 11:50 AEDT
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (HU3 | Humanities 3).