POWER OUTAGE - TLC [BUNDOORA]

Incident Report for LTU | Outages

Resolved

This incident has been resolved.
Posted Apr 04, 2023 - 09:05 AEST

Investigating

The power supply to The Learning Commons has been interrupted. The I&O team are working to identify the cause and implement a solution.
Posted Feb 08, 2023 - 10:42 AEDT
This incident affected: Melbourne (Bundoora) Campus Buildings (TLC | The Learning Commons).