POWER OUTAGE / SAFETY SWITCH TESTING -LIMS2 [BUNDOORA]

Scheduled for Jun 26, 07:00 - 09:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 15, 2026 - 13:02 AEST

Scheduled

The power supply to LaTrobe Institute For Molecular Science 2 Levels 1 to 4 will be interrupted on from Friday 26th June 2026 from 7:00AM to 9:00AM to allow for Residual Current Device (RCD) / safety switch testing. These works will incur a minor power outage for up to 10 seconds on each circuit tested.
Posted Jun 15, 2026 - 13:02 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (LIMS2 | LaTrobe Institute For Molecular Science 2).