LIFT & AUTO DOOR OUTAGE - AW [BUNDOORA]
Incident Report for LTU | Outages
Resolved
This incident has been resolved.
Posted May 06, 2024 - 11:49 AEST
Investigating
The lift and auto door in Sylivia Walton Building will be unavailable on Tuesday 23 April 2024 from 12:30 - 4pm to allow for maintenance works.
Posted Apr 23, 2024 - 12:34 AEST
This incident affected: Melbourne (Bundoora) Campus Buildings (SW | Sylvia Walton building).