PROJECT WORKS - PS1 [BUNDOORA]

Scheduled for Jul 4, 07:00 AEST  -  Jul 5, 16:00 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 29, 2026 - 15:53 AEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 29, 2026 - 15:51 AEST

Scheduled

Physical Science 1 will be undergoing project works. The estimated time of completion is on Sunday 5th July 2026 at 4:00PM. This project may generate some construction noise and access restrictions [delete as applicable] during this time.
Posted Jun 29, 2026 - 15:51 AEST
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (PS1 | Physical Sciences 1).