HOTWATER OUTAGE - GS [BUNDOORA]
Incident Report for LTU | Outages
Resolved
This incident has been resolved.
Posted Feb 08, 2021 - 15:04 AEDT
Investigating
Hot Water services in George Singer Building have been interrupted. The I&O team are working to identify the cause and implement a solution.
Posted Aug 18, 2020 - 10:57 AEST
This incident affected: Melbourne (Bundoora) Campus Buildings (GS | George Singer Building).