AIR-CONDITIONING OUTAGE - TC [BUNDOORA]
Incident Report for LTU | Outages
Resolved
This incident has been resolved.
Posted May 12, 2021 - 10:22 AEST
Investigating
Air-conditioning services on levels 2,3 & 4 in Thomas Cherry Building have been interrupted. The I&O team are working to identify the cause and implement a solution.
Posted Dec 03, 2020 - 16:34 AEDT
This incident affected: Melbourne (Bundoora) Campus Buildings (TC | Thomas Cherry Building).