AIR-CONDITIONING OUTAGE - HS2 [BUNDOORA]
Incident Report for LTU | Outages
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 16:06 AEST
Investigating
Air-conditioning services in Health Sciences 2 have been interrupted. The I&O team are working to identify the cause and implement a solution.
Posted Mar 20, 2020 - 09:39 AEDT
This incident affected: Melbourne (Bundoora) Campus Buildings (HS2 | Health Sciences 2).