POWER OUTAGE - PW [BUNDOORA]
Incident Report for LTU | Outages
Resolved
This incident has been resolved.
Posted Feb 08, 2021 - 15:03 AEDT
Investigating
The power supply to Peribolos West, level 2 will be interrupted from 2:00 pm to 3:00 pm Friday 20th November to allow for scheduled maintenance works.
Posted Nov 20, 2020 - 13:45 AEDT
This incident affected: Melbourne (Bundoora) Campus Buildings (PW | Peribolos West).