CONSTRUCTION NOISE/RESTRICTED ACCESS - P13 CAR PARK 13 [BENDIGO]
Incident Report for LTU | Outages
Resolved
This incident has been resolved.
Posted May 12, 2021 - 10:26 AEST
Investigating
Access to Car Park 13 will be restricted from 07:30 am to 5:00pm Friday 9th April to allow for scheduled works. These works involve using a grinding machine
Posted Apr 08, 2021 - 08:30 AEST
This incident affected: Bendigo Campus Grounds (P13 | Car Park 13).