BUILDING FABRICS PROJECT WORKS - LIMS1 [BUNDOORA]

Scheduled for Dec 8, 07:00 AEDT  -  Dec 18, 15:00 AEDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Dec 02, 2025 - 16:09 AEDT

Scheduled

LaTrobe Institute For Molecular Science 1 will be undergoing Building Fabric Works. The estimated time of completion is Thursday 18 Dec 25. This project may generate some construction noise and external walkway will have limited access.
Posted Dec 02, 2025 - 16:09 AEDT
This scheduled maintenance affects: Melbourne (Bundoora) Campus Buildings (LIMS1 | LaTrobe Institute For Molecular Science 1).