RESTRICTED ACCESS - HA2 [BENDIGO]
Incident Report for LTU | Outages
Resolved
This incident has been resolved.
Posted Nov 06, 2020 - 10:58 AEDT
Investigating
Access to Hillside Apartments 2, will now be restricted until 4:30 pm Monday 2nd November to allow for scheduled carpet and vinyl replacement works.
Posted Oct 27, 2020 - 10:32 AEDT
This incident affected: Bendigo Campus Buildings (HA2 | Hillside Apartments 2).