AIR-CONDITIONING/HEATING OUTAGE - HHS2 [BENDIGO]
Incident Report for LTU | Outages
Resolved
This incident has been resolved.
Posted Jun 17, 2021 - 12:47 AEST
Investigating
Air-conditioning/Heating services in LaTrobe Rural Health School (LRHS) Building have been interrupted. The I&O team are working to identify the cause and implement a solution.
Posted Jun 09, 2021 - 08:00 AEST
This incident affected: Bendigo Campus Buildings (HHS2 | LaTrobe Rural Health School (LRHS)).