HOT WATER OUTAGE - U [BUNDOORA]
Incident Report for LTU | Outages
Resolved
This incident has been resolved.
Posted Nov 10, 2021 - 15:13 AEDT
Investigating
The hot water supply to Union Building has been interrupted. The I&O team are working to identify the cause and implement a solution.
Posted Sep 02, 2021 - 14:24 AEST
This incident affected: Melbourne (Bundoora) Campus Buildings (U | Union Building).